LEGO Harry Potter: Years 1-4
TT Games
 79
Minimum: 149
CPU: 
Intel P4 1.8 GHz/AMD Athlon XP 2200+
GPU: 
ATI X1300/NVIDIA GeForce FX 5800 (256 MB RAM)
RAM: Unavailable
OS: 
Windows XP/Vista
Fill in your PC information to see if it runs LEGO Harry Potter: Years 1-4
Confirm
Requirements
LEGO Harry Potter: Years 1-4
TT Games
Minimum: 149
CPU: 
Intel P4 1.8 GHz/AMD Athlon XP 2200+
GPU: 
ATI X1300/NVIDIA GeForce FX 5800 (256 MB RAM)
RAM: Unavailable
OS: 
Windows XP/Vista
Homepage
Desktop Site
Fill out the specs below:
How do I know these specs?
Confirm
Where do I find these specs?
For Mac
Click on the Apple button on the top left corner, and click "about this Mac". A window with the specs of your Mac should appear.
For Windows
Type dxdiag in the search bar in the Windows menu and click dxdiag. Click on the "Display" tab of the dxdiag window to see your graphics card information.
Find out if my PC can run it
Return